[L2Ork-dev] Purr Data 2.9.0 released

Steve Morris morris at buinea.com
Thu Apr 18 00:23:47 EDT 2019

Hello again

It's been a while since I waded through makefiles, but I think I see the
problem, and a solution that works for me.

I went back and tried to build the previous version, but that fails in
the same way unable to include magick/MagicCore.h

It seems ImageMagick has changed. I looked at the code for imagemagick-6
and it had a 'magick' directory. My current imagemagick-7 does not.

I tried to downgrade imagemagick but started to run into dependency
issues and I didn't want to take down my entire machine.

I was able to work around it for my needs by running 'make incremental'.

This is enough to get me running again, but certainly not the general


On Wed, Apr 17, 2019 at 07:12:52PM -0400, Jonathan Wilkes wrote:
> On Wed, Apr 17, 2019 at 5:03 PM Steve Morris <morris at buinea.com> wrote:
> >
> > Hi All,
> >
> > I am unable to build this on a current Archlinux x86_64 system.
> >
> > I was previously able to build and run ver 2.8.1
> That's strange-- there has been no change to anything related to Gem
> between the two versions.
> Albert-- any ideas on what could have happened?
> -Jonathan
> _______________________________________________
> L2Ork-dev mailing list
> L2Ork-dev at disis.music.vt.edu
> https://disis.music.vt.edu/listinfo/l2ork-dev

More information about the L2Ork-dev mailing list