[L2Ork-dev] Help a complete Linux noob install pd-l2ork!

Tianyu Ge tianyu at vt.edu
Tue Jan 6 01:34:37 UTC 2015

Hey Reed,

The problem with 64-bit installation looks like that some dependencies
required for pd-l2ork are not fulfilled, namely libtk8.5. Could you try to
manually install it, and then run the program again?

# apt-get install libtk8.5
*(# denotes elevated permission; same below)*

Regarding pd-vanilla: I have not tried to install pd-vanilla along with
pd-l2ork so I'm not aware of any potential conflicts. To uninstall
pd-vanilla, go to the directory where you compiled it and run the makefile.
It should be under the src folder if I recall correctly.

# make uninstall
# make clean

Hope that helps.


On Tue, Jan 6, 2015 at 9:02 AM, Reed Perkins <reedperkins32 at gmail.com>

> Hi folks,
> I am trying to install pd-l2ork in Linux Mint 17.1 and have run into some
> problems. Noob disclaimer: I am not tech-savvy. I have never 'compiled'
> anything or used Termnal before etc. However I REALLY want to try out
> pd-l2ork because it seems to have so many awesome features that I wish
> pd-extended had.
> Here's what I've done so far:
> I partitioned my hard drive (running OS 10.9 on a macbook pro) and
> installed the latest version of Linux Mint. I went to the Virginia Tech
> site and followed the instructions exactly. I downloaded the 32-bit .deb
> file, opened it with package installer, installed the missing dependencies
> with sudo apt-get install -f and....nothing. No icons, no evidence that
> pd-l2ork has been installed anywhere. I type in "pd-l2ork" into Terminal
> and i get "pd-l2ork: command not found", I try searching for the program
> itself on the hard disk and...nothing.
> I tried again with the 64-bit .deb file. The 4 icons appear, as well as a
> bunch of l2ork related stuff in /usr/bin/ and /usr/lib, but when I try to
> run the program, all I get it the following error--
> usr/lib/pd-l2ork/bin/pd-gui: error while loading shared libraries:
> libtk8.5.so: cannot open shared object file: No such file or directory
> --then something called watchdog keeps trying to signal pd and freezes up
> the terminal.
> I installed pd-vanilla earlier to make sure I could actually install
> something when I wasn't able to get pd-l2ork to run, and vanilla works just
> fne. So it sounds like maybe they can't coexist? If that's the case how do
> I get rid of Vanilla?
>  I have no idea how to troubleshoot in Linux so if anyone could give me
> some pointers that would be awesome!!
> Thanks,
> Reed
> _______________________________________________
> L2Ork-dev mailing list
> L2Ork-dev at disis.music.vt.edu
> http://disis.music.vt.edu/listinfo/l2ork-dev


Tianyu GE 葛天宇 (tianyu at vt.edu)


*My PGP key can be found here
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://disis.music.vt.edu/pipermail/l2ork-dev/attachments/20150106/2f51f6ea/attachment.html>

More information about the L2Ork-dev mailing list