[L2Ork-dev] Purr Data 2.9.0 released

Steve Morris morris at buinea.com
Wed Apr 17 17:02:57 EDT 2019

Hi All,

I am unable to build this on a current Archlinux x86_64 system.

I was previously able to build and run ver 2.8.1

The first problem I encountered was apparently solved by installing gsl,
which appears to be a new dependency.

Then I had difficulty with 'magick/MagickCore.h' not found.

On my system I have /usr/include/ImageMagick-7/MagickCore/MagickCore.h

so I started anew and ran 

git clone https://git.purrdata.net/jwilkes/purr-data.git
make checkout
grep -r -I -l MagickCore.h .

I edited the 2 cpp files, changing 

#include <magick/MagickCore.h>
#include <MagickCore/MagickCore.h>

and tried again.

This time it errors out with:

Making install in build
make[5]: Entering directory '/home/morris/proj/purr-data/Gem/build'
make[6]: Entering directory '/home/morris/proj/purr-data/Gem/build'
make[6]: Nothing to be done for 'install-exec-am'.
make[6]: Nothing to be done for 'install-data-am'.
make[6]: Leaving directory '/home/morris/proj/purr-data/Gem/build'
make[5]: Leaving directory '/home/morris/proj/purr-data/Gem/build'
Making install in plugins
make[5]: Entering directory '/home/morris/proj/purr-data/Gem/plugins'
Making install in imageMAGICK
make[6]: Entering directory '/home/morris/proj/purr-data/Gem/plugins/imageMAGICK'
/bin/sh ../../libtool  --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../../src  -I../../src   -DPD -I/home/morris/proj/purr-data/pd/src  -I/usr/include/ImageMagick-7 -fopenmp -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=16  -DHAVE_S_STUFF_H  -freg-struct-return -O3 -falign-loops -falign-functions -falign-jumps -funroll-loops -ffast-math -mmmx -MT gem_imageMAGICK_la-imageMAGICK.lo -MD -MP -MF .deps/gem_imageMAGICK_la-imageMAGICK.Tpo -c -o gem_imageMAGICK_la-imageMAGICK.lo `test -f 'imageMAGICK.cpp' || echo './'`imageMAGICK.cpp
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../../src -I../../src -DPD -I/home/morris/proj/purr-data/pd/src -I/usr/include/ImageMagick-7 -fopenmp -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=16 -DHAVE_S_STUFF_H -freg-struct-return -O3 -falign-loops -falign-functions -falign-jumps -funroll-loops -ffast-math -mmmx -MT gem_imageMAGICK_la-imageMAGICK.lo -MD -MP -MF .deps/gem_imageMAGICK_la-imageMAGICK.Tpo -c imageMAGICK.cpp  -fPIC -DPIC -o .libs/gem_imageMAGICK_la-imageMAGICK.o
imageMAGICK.cpp: In constructor ‘gem::plugins::imageMAGICK::imageMAGICK()’:
imageMAGICK.cpp:93:7: error: ‘IsMagickInstantiated’ was not declared in this scope
imageMAGICK.cpp:93:7: note: suggested alternative: ‘IsMagickCoreInstantiated’
imageMAGICK.cpp:100:3: error: ‘GetExceptionInfo’ was not declared in this scope
imageMAGICK.cpp:100:3: note: suggested alternative: ‘ExceptionInfo’
[morris at moe purr-data]$

And thats where it stans now. Perhaps I am making a simple mistake.


On Wed, Apr 17, 2019 at 12:19:11AM -0400, Jonathan Wilkes wrote:
> Hi list,
> Purr Data 2.9.0 is now available:
> https://github.com/jonwwilkes/purr-data/releases/tag/2.9.0

More information about the L2Ork-dev mailing list